MLDonkey Forum Index
Homepage •  Bugs •  Tasks •  Patches •  SF.net Project Page •  ChangeLog •  German forum •  Links •  Wiki •  Downloads
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
 
mld 3.1.5 error while loading libminiupnpc.so.10

 
Post new topic   Reply to topic    MLDonkey Forum Index -> Alternative platforms
View previous topic :: View next topic  
Author Message
Tokka
neophyte


Joined: 06 Jun 2008
Posts: 21
Location: Italy

PostPosted: Mon Feb 09, 2015 8:14 pm    Post subject: mld 3.1.5 error while loading libminiupnpc.so.10 Reply with quote

Hi all, for some reasons i had to rollback my ubuntu pc from mint 17 to mint 13 (64bit).
Using the last core i compiled it doesn't start, so i recompiled it with the result:
Quote:
Configuring MLDonkey 3.1.5 completed.

Network modules:
- eDonkey enabled (eMule SUI enabled)
- BitTorrent enabled
- FileTP (aka wget) enabled
- Fasttrack enabled
- Gnutella disabled - unmaintained
- Gnutella2 disabled - unmaintained
- Direct Connect enabled
- Open Napster disabled - currently not usable
- Soulseek disabled - currently not usable
- OpenFT disabled - currently not usable

Core features:
- zlib (required) enabled
- threads enabled
- bzip2 enabled
- iconv enabled
- libmagic enabled
- upnp & natpmp enabled
- graphical stats enabled
- png support enabled
- jpg support enabled

Compilers:
- OCaml version 3.12.0
- gcc version 4.6
- g++ version 4.6

\nNow execute 'make' to start compiling. Good luck!


but when i try to start mlnet i have

Quote:
./mlnet
./mlnet: error while loading shared libraries: libminiupnpc.so.10: cannot open shared object file: No such file or directory


Libminiupnpc-dev and libminiupnpc-8 (the :i386 version too), but mld still doesn't start (on mint 17 it worked without any problem, but only tested on 32bit machines Sad )

Hope in some hints, thanks Smile
Tk
Back to top
View user's profile Send private message
ygrek
professional


Joined: 20 Mar 2010
Posts: 610

PostPosted: Wed Feb 11, 2015 7:13 am    Post subject: Reply with quote

libminiupnpc.so.10 is in package libminiupnpc10, probably your -dev package was updated to testing, but not the runtime library
_________________
Download | Report bugs | git mirror
Back to top
View user's profile Send private message Visit poster's website
Tokka
neophyte


Joined: 06 Jun 2008
Posts: 21
Location: Italy

PostPosted: Wed Feb 11, 2015 2:51 pm    Post subject: Reply with quote

Hi Ygrek, my os is mint 13, based on ubuntu 12, and libminiupnpc-dev is 1.6-3, so it is old Sad
But compiling mld it use libminiupnpc10 (1.9). Compiling mld 3.1.5 on an amr machine with ubuntu 12 it worked fine. This difference is given by the 64 bit version in your opinion? Otherwise i don't see any reason why it don't works Sad
The only differences between the 2 compilations are that for amrhf i've had to install the required packages on the machine, coz the the self-download did not work on it.
Is this another possible issue?
Thanks Smile
Tk
Back to top
View user's profile Send private message
ygrek
professional


Joined: 20 Mar 2010
Posts: 610

PostPosted: Fri Feb 13, 2015 5:20 am    Post subject: Reply with quote

If you don't actually need upnp functionality - you can just configure with --disable-upnp-natpmp
Otherwise please show dpkg -l |grep upnp and full mldonkey configure output
_________________
Download | Report bugs | git mirror
Back to top
View user's profile Send private message Visit poster's website
Tokka
neophyte


Joined: 06 Jun 2008
Posts: 21
Location: Italy

PostPosted: Fri Feb 20, 2015 3:50 pm    Post subject: Reply with quote

Hi Ygrek, sorry for the delay.
I made some tries, and for the moment the result is:
installe libminiupnpc from the downloaded packages, and this fixed the lib error, but...after that, other lib errors (like libgd.so.3).
Tried the same on an ubuntu 12 armhf, and no error, works fine (installed mld 3.1.3 and replaced mlnet with the precompiled 3.1.5 amrhf).
And with a new compilation (on x64) it give me some errors.
I'll try to install the packages (not the self-download) to see if it fix.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    MLDonkey Forum Index -> Alternative platforms All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Sourceforge.net Logo